RIPの設定 (2)

昨日に引続きRIPの設定を見ていきましょう

先ず、対抗ルータのloopback0へpingを実施してみましょう

[edit]
root# run ping 172.16.0.1 count 5 rapid
PING 172.16.0.1 (172.16.0.1): 56 data bytes
!!!!!
— 172.16.0.1 ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.055/0.073/0.141/0.034 ms

[edit]
root#

問題なく疎通確認ができました
ちなみに上のようにpingへcount 5オプションとrapidオプションを付加させてあげる事により某社ルータと同じような出力を得ることができます
では対抗側の250側0よりこちら側のlo0インターフェースは見えているのでしょうか?
早速確認してみましょう

test-router>ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
test-router>

おやおや? 通信確認ができていません
ではJUNOS側に次のコンフィグを上書きしてみてください

[edit]
root# load override terminal
[Type ^D at a new line to end input]
version 7.4R3.4;
system {
    root-authentication {
        encrypted-password “$1$IRx5CsNE$9fS4RQv8HpGFlXW9E6T8T.”; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 172.16.0.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.10.1/32;
            }
        }
    }
}
protocols {
    rip {
        group plan-g {
            export redist-direct;
            neighbor fxp0.0;
        }
    }
}
policy-options {
    policy-statement redist-direct {
        from protocol direct;
        then accept;
    }
}

load complete

[edit]
root#

では、投入したコンフィグが前回のコンフィグと何が違うか見てみましょう

[edit]
root# show |compare
[edit protocols rip group plan-g]
+    export redist-direct;
[edit]
+  policy-options {
+      policy-statement redist-direct {
+          from protocol direct;
+          then accept;
+      }
+  }

[edit]
root#

lo0インターフェースはダイレクト接続となっているので、redistribute directつまりダイレクト接続されたlo0のルート情報を再広報していますね
ではcommitを実施し2500から見えるようになったか確認してみましょう

test-router>ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
test-router>

pingによる接続性の確認が取れました

以上、JUNOSのRIPルーティングでした

タグ

2009年9月27日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

RIPの設定 (1)

前回はstatic routingを実施しましたが今回はdynamic routingの基礎であるRIPを学習します

通信相手としてモノリシックOSを搭載し、投入したコマンドは何も考えず即座に反映してしまう彼に再登場してもらいます

さて今回使用するコンフィグはこのようになっています

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname test-router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface Ethernet0
 ip address 172.16.0.2 255.255.255.0
 no shutdown
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.0.0
 network 192.168.10.0
!
ip http server
ip classless
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

ここで解説をしておきますとrouter ripへ”version 2″コマンドを投入していますが、
これはJUNOSはデフォルトでRIPv2モードになっているためです
またそれぞれのネットワークは….

CIsco⇔Juniper間のセグメント・・172.16.0.0/24
  Juniper側 fxp0・・・・・・172.16.0.1
  Cisco側 Ethernet0・・172.16.0.2
Ciscoのloopbackアドレス・・・・・・192.168.0.0/32
Juniperのループバックアドレス・・192.168.10.0/32

となっております

早速この環境に合わせてJuniper側の設定を開始いたしましょう
まずはfxp0とlo0の各インターフェースへIPアドレスを設定します

[edit]
root# set interfaces fxp0 unit 0 family inet address 172.16.0.1/24

[edit]
root# set interfaces lo0 unit 0 family inet address 192.168.10.1/32

次にRIPの設定を実施します
JUNOSでRIPの設定を行う場合RIPグループを作成しneghborとなるルータが接続されているインターフェースを入力します
実際のコマンドは次のようになります
set protocols rip group RIPグループ名 neighbor UNIT番号を含むインターフェース名
早速設定入力し、commitしてみましょう

[edit]
root# set protocols rip group plan-g neighbor xp0.0

[edit]
root# show | no-more
version 7.4R3.4;
system {
    root-authentication {
        encrypted-password “$1$IRx5CsNE$9fS4RQv8HpGFlXW9E6T8T.”; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 172.16.0.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.10.1/32;
            }
        }
    }
}
protocols {
    rip {
        group plan-g {
            neighbor fxp0.0;
        }
    }
}

[edit]
root# commit
commit complete

[edit]
root#

以上でRIPの設定が終了いたしました

では、確認のため“routing table”を見てみましょう

[edit]
root# run show route

inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, – = Last Active, * = Both

172.16.0.0/24      *[Direct/0] 00:41:47
                    > via fxp0.0
172.16.0.1/32      *[Local/0] 00:41:47
                      Local via fxp0.0
192.168.0.0/24     *[RIP/100] 00:35:34, metric 2, tag 0
                    > to 172.16.0.2 via fxp0.0
192.168.10.1/32    *[Direct/0] 00:41:47
                    > via lo0.0
224.0.0.9/32       *[RIP/100] 00:05:22, metric 1
                      MultiRecv

__juniper_private1__.inet6.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
+ = Active Route, – = Last Active, * = Both

fe80::2e0:b6ff:fe06:286b/128
                   *[Direct/0] 00:41:47
                    > via lo0.16385

[edit]
root#

問題なく対抗ルータのLoopback0インターフェースのアドレスを取得していますね

さて次回も引続きRIPについて学習していきましょう

タグ

2009年9月26日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

このページの先頭へ