Virtual Routerの設定

JuniperのJ-Netコミュニティ日本語版にてSRXのVirtual Routerが可能か話題に上がっていたのでVirtual Routerを設定してみました

下記コマンドにてバーチャルルータのルーティングインスタンスを作成
 set routing-instances <インスタンス名> instance-type virtual-router

作成したインスタンスにインターフェースをアサインしていく形で設定できますね
 set routing-instances <インスタンス名> interface <インターフェース名>

ちなみにvrfは"set routing-instances <インスタンス名> instance-type vrf"です

リモートラボ検証環境で作ったコンフィグファイルを貼り付けておきます

JunosBOX#1の設定

[edit]
root@M40-1# show | no-more
## Last changed: 2010-08-14 10:57:48 UTC
version 10.0R1.8;
/* 2010/08/13 */
system {
    host-name M40-1;
    root-authentication {
        encrypted-password "$1$5GF/SjEl$AZ8jGfR/Ln5rEix1KlkO91"; ## SECRET-DATA
    }
    login {
        user Juniper {
            uid 2001;
            class super-user;
            authentication {
                encrypted-password "$1$X972PvyC$Nb9KzEIyHvhvptKE8OoDT0"; ## SECRET-DATA
            }
        }
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 10.0.0.254/24;
            }
        }
    }
    fxp1 {
        unit 0 {
            family inet {
                address 10.0.1.254/24;
            }
        }
    }
    fxp2 {
        unit 0 {
            family inet {
                address 10.0.2.254/24;
            }
        }
    }
    fxp3 {
        unit 0 {
            family inet {
                address 10.0.3.254/24;
            }
        }
    }
}
routing-instances {
    vr1 {
        instance-type virtual-router;
        interface fxp0.0;
        interface fxp2.0;
    }
    vr2 {
        instance-type virtual-router;
        interface fxp1.0;
        interface fxp3.0;
    }
}

[edit]
root@M40-1#
 
JunosBOX#2の設定

[edit]
Juniper@M40-2# show
## Last changed: 2010-08-15 01:12:07 UTC
version 9.3R4.4;
system {
    host-name M40-2;
    root-authentication {
        encrypted-password "$1$sv6ia7vp$xLJkuk2v0OjVUz0zLnXiW1"; ## SECRET-DATA
    }
    login {
        user Juniper {
            uid 2000;
            class super-user;
            authentication {
                encrypted-password "$1$oEOKFHM3$S5XwJ3EIKSB3VqPNqpMkn/"; ## SECRET-DATA
            }
        }
    }
}
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 10.0.0.253/24;
            }
        }
    }
    fxp1 {
        unit 0 {
            family inet {
                address 10.0.1.253/24;
            }
        }
    }
    inactive: fxp2 {
        unit 0;
    }
    inactive: fxp3 {
        unit 0;
    }
}
routing-instances {
    vr1 {
        instance-type virtual-router;
        interface fxp0.0;
        routing-options {
            static {
                route 10.0.2.0/24 next-hop 10.0.0.254;
            }
        }
    }
    vr2 {
        instance-type virtual-router;
        interface fxp1.0;
        routing-options {
            static {
                route 10.0.3.0/24 next-hop 10.0.1.254;
            }
        }
    }
}

[edit]
Juniper@M40-2#
 
ついでにCiscoもPing端末がわりに使用したので、コンフィグを貼りつけ
 
Cisco1812J#1

CiscoR-1#show run
Building configuration...

Current configuration : 1223 bytes
!
version 12.4
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
no service password-encryption
!
hostname CiscoR-1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet0
 ip address 10.0.2.253 255.255.255.0
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet2
!
interface FastEthernet3
 shutdown
!
interface FastEthernet4
 shutdown
!
interface FastEthernet5
 shutdown
!
interface FastEthernet6
 shutdown
!
interface FastEthernet7
 shutdown
!
interface FastEthernet8
 shutdown
!
interface FastEthernet9
 shutdown
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.2.254
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

CiscoR-1#
 
Cisco1812J#2

CiscoR-2#sh run
Building configuration...

Current configuration : 1246 bytes
!
version 12.4
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
no service password-encryption
!
hostname CiscoR-2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet0
 ip address 10.0.3.253 255.255.255.0
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet2
!
interface FastEthernet3
 shutdown
!
interface FastEthernet4
 shutdown
!
interface FastEthernet5
 shutdown
!
interface FastEthernet6
 shutdown
!
interface FastEthernet7
 shutdown
!
interface FastEthernet8
 shutdown
!
interface FastEthernet9
 shutdown
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.3.254
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

CiscoR-2#

(2010/08/20編集)
Junosのコンフィグにいろいろゴミが入っていたので編集しました
一般公開しているのでいろいろな人が触るから気をつけないとね。。

タグ

2010年8月15日 | コメント/トラックバック(6) |

カテゴリー:JUNOS

link aggrigationの設定 (1)

link aggrigationの第1回目です

本来ならJuniper EXシリーズとCisco Catalyst間でLAG接続を実施したいところですが、手元にEXシリーズが無いのでSRX100で代用します
またCisco側はCatalyst2950-12を使用します

まずはスタンダードなLACPによるLAG接続です

Catalyst2950側の設定は下記設定を実施しています

Current configuration : 958 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
spanning-tree mode rapid-pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface Port-channel1
flowcontrol send off
!
interface FastEthernet0/1
channel-group 1 mode passive
!
interface FastEthernet0/2
channel-group 1 mode passive
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface Vlan1
ip address 10.0.0.1 255.255.255.0
no ip route-cache
!
ip default-gateway 10.0.0.254
ip http server
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
!
end

では、SRX側を設定していきます
Junosの場合は、まず最初に、いくつのLAGを使用するかを設定してあげなければなりません
下記コマンドにてLAG数の最大値を設定してあげます

[edit]
Juniper@SRX100# set chassis aggregated-devices ethernet device-count 1

[edit]
Juniper@SRX100#

次に実際にLAGを構成する物理インターフェースを設定します
今回は”fe-0/0/0″と”fe-0/0/1″を使用しましょう
インターフェースごとにに設定を実施しても良いのですが手っ取り早く”interface-range”コマンドを使用します

[edit]
Juniper@SRX100# set interfaces interface-range AE_INT_RANGE member-range fe-0/0/0 to fe-0/0/1

[edit]
Juniper@SRX100# set interfaces interface-range AE_INT_RANGE fastether-options 802.3ad ae0

簡単に解説をします

まずAE_INT_RANGEとなっている部分はinterface-rangeのレンジ名です
目的に合った分かりやすい名前がいいでしょう
物理インターフェース番号が連続しているのでmember-rangeコマンドも使用しています
個々にメンバーを設定することも可能です
ex: set interfaces interface-range AE_INT_RANGE member fe-0/0/0

LAGの設定は
interface <物理インターフェース名> fastether-option 802.3ad <LAGインターフェース名>
となります

LAGインターフェース名は必ず”ae<LAGインターフェース番号>“となります

ちなみにaeとは”aggregated ethernet”のことです
なお、今回は物理インターフェースがFastEthernetなのでfastether-optionを使用していますが、GigaEthernetの場合はgigaether-optionを使用します

では作成したLAGインターフェースをスイッチポートに設定して、リンクアグリゲーションのプロトコルを”lacp”にしましょう
Catalyst側を”passive”設定にしていますので必然的にSRX側は”active”設定にしなくてはなりません

[edit]
Juniper@SRX100# set interfaces ae0 unit 0 family ethernet-switching

[edit]
Juniper@SRX100# set interfaces ae0 aggregated-ether-options lacp active

LAGインターフェースが出来たらVLANに紐付けを行います

[edit]
Juniper@SRX100# set vlans AE_VLAN interface ae0.0

[edit]
Juniper@SRX100# set vlans AE_VLAN vlan-id 3

[edit]
Juniper@SRX100# set vlans AE_VLAN l3-interface vlan.0

“AE_VLAN”はVLAN名です

また”ae0.0″や”vlan.0″はそれぞれ”ae0 unit 0″、”vlan unit 0″のことですが、
set vlans AE_VLAN interface ae0 unit 0
といった形ではコマンド投入できません

下記コマンドにてVLAN-ID3 “AE_VLAN”をvlanインターフェース番号”unit 0″に紐付けしています
set vlans AE_VLAN l3-interface vlan.0

最後にvlanインターフェースの設定です
ルーティングインターフェースになりますのでここでIPアドレスを設定します

[edit]
Juniper@SRX100# set interfaces vlan unit 0 family inet address 10.0.0.254/24

以上で、lacpの設定は完了です

が、次回の検証のために”fe-0/0/7″をルーテッドポートに設定しておきます

[edit]
Juniper@SRX100# set interfaces fe-0/0/7 unit 0 family inet address 192.168.0.1/24

また使用している機器がSRXですのでゾーン設定とポリシー設定も追加しておきます

[edit]
Juniper@SRX100# set security zones security-zone trust interfaces fe-0/0/7.0

[edit]
Juniper@SRX100# set security zones security-zone trust interfaces vlan.0

[edit]
Juniper@SRX100# set security policies from-zone trust to-zone trust policy TRUST_POLICY match source-address any

[edit]
Juniper@SRX100# set security policies from-zone trust to-zone trust policy TRUST_POLICY match destination-address any

[edit]
Juniper@SRX100# set security policies from-zone trust to-zone trust policy TRUST_POLICY match application any

[edit]
Juniper@SRX100# set security policies from-zone trust to-zone trust policy TRUST_POLICY then permit

簡単に解説すると”fe-0/0/7.0″と”vlan.0″を”trust”ゾーンにアサインし、”trust”ゾーン間の通信を全許可にしています
出来上がったconfigを見てみましょう

[edit]
root# show | no-more

## Last changed: 2010-08-07 12:20:29 UTC
version 10.1R2.8;
system {
    host-name SRX100;
    root-authentication {
        encrypted-password "$1$NiMStrSt$ES0FVylRA34hx6HXDAtpx1"; ## SECRET-DATA
    }
    login {
        user Juniper {
            class super-user;
            authentication {
                encrypted-password "$1$F1x9Dyky$l5d1mfjcqe2hZVhkTMBAL."; ## SECRET-DATA
            }
        }
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 1;
        }
    }
}
interfaces {
    interface-range AE_INT_RANGE {
        member-range fe-0/0/0 to fe-0/0/1;
        fastether-options {
            802.3ad ae0;
        }
    }
    fe-0/0/7 {
        unit 0 {
            family inet {
                address 192.168.0.1/24;
            }
        }
    }
    ae0 {
        aggregated-ether-options {
            lacp {
                active;
            }
        }
        unit 0 {
            family ethernet-switching;
        }
    }
    vlan {
        unit 0 {
            family inet {
                address 10.0.0.254/24;
            }
        }
    }
}
security {
    zones {
        security-zone trust {
            interfaces {
                fe-0/0/7.0;
                vlan.0;
            }
        }
    }
    policies {
        from-zone trust to-zone trust {
            policy TRUST_POLICY {
                match {
                    source-address any;
                    destination-address any;
                    application any;
                }
                then {
                    permit;
                }
            }
        }
    }
}
vlans {
    AE_VLAN {
        vlan-id 3;
        interface {
            ae0.0;
        }
        l3-interface vlan.0;
    }
}

[edit]
root#

では、次回lacp検証の実施、次々回はlacp+vlan taggingを解説いたします

タグ

2010年8月7日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

JUNOSのアップグレード (実施編)

Junosのアップグレード 2回目です 今回は実際にアップグレードを実施していきます。
今回は私の手元にあるSRX100を例に実施いたします。
前回のブログを参考に必要なJunosを入手したら動作しているJunosのバックアップを実施しましょう。
CIscoルータにてIOSのアップグレードを行う場合においてもいざというときに備えてIOSを取得しておくことは常識だと思いますが、Juniper製品の場合でも、もしものことを考えてJunosのバックアップを取得しておくことをお勧めします。
Junosのバックアップ用に1GBのUSBフラッシュドライブを用意しました。
SRX100に内蔵されているflashは1GBなので1GBのUSBフラッシュで十分と思われます。
用意したUSBフラッシュをSRX100の前面にあるUSBポートへ挿入し起動させます。
Junosが起動したらまず最初にのどのデバイスからJunosが起動しているか確認を行います。(※ USBフラッシュから起動をしていないことの確認)

root> show system storage
Filesystem              Size       Used      Avail  Capacity   Mounted on
/dev/da0s1a             293M       190M        80M       70%  /
devfs                   1.0K       1.0K         0B      100%  /dev
/dev/md0                528M       528M         0B      100%  /junos
/cf                     293M       190M        80M       70%  /junos/cf
devfs                   1.0K       1.0K         0B      100%  /junos/dev/
procfs                  4.0K       4.0K         0B      100%  /proc
/dev/bo0s3e              24M        20K        22M        0%  /config
/dev/bo0s3f             342M        20M       295M        6%  /cf/var
/dev/md1                 84M        12M        65M       16%  /mfs
/cf/var/jail            342M        20M       295M        6%  /jail/var
devfs                   1.0K       1.0K         0B      100%  /jail/dev
/dev/md2                1.8M       4.0K       1.7M        0%  /jail/mfs
SRXの場合は/dev/da0s1aが内部フラッシュストレージです。
現在稼働しているJunosのバージョンの確認も行っておきましょう。
root> show version
Model: srx100-lm
JUNOS Software Release [10.1R1.8]

root> 

Junos10.1R1.8が稼働中であることを確認できます。
Junosの起動デバイスを確認したら次のコマンドで動作中のJunosをUSBフラッシュへバックアップします。
> request system snapshot media usb partition
(M/TシリーズではOSバックアップにUSBを使用しませんので”media usb”の箇所は不要です)
ここでusbフラッシュがフォーマットされますので少し時間がかかります
実行結果は次のようになります
root> request system snapshot media usb partition
Clearing current label…
Partitioning usb media (/dev/da1) …
Partitions on snapshot:

  Partition  Mountpoint  Size    Snapshot argument
      s1a    /altroot    284M    none
      s2a    /           284M    none
      s3e    /config     23M     none
      s3f    /var        335M    none
      s4a    recovery    29M     none
Copying ‘/dev/da0s1a’ to ‘/dev/da1s1a’ .. (this may take a few minutes)
Copying ‘/dev/da0s2a’ to ‘/dev/da1s2a’ .. (this may take a few minutes)
Copying ‘/dev/da0s3e’ to ‘/dev/da1s3e’ .. (this may take a few minutes)
Copying ‘/dev/da0s3f’ to ‘/dev/da1s3f’ .. (this may take a few minutes)
Copying ‘/dev/da0s4a’ to ‘/dev/da1s4a’ .. (this may take a few minutes)
The following filesystems were archived: /altroot / /config /var recovery

root>

ここまで済んだら次にSRX100の設定を行います。

今回はFTPサーバを使用しますのでFTP通信が可能なように設定を行います。

root> configure
Entering configuration mode

[edit]
root# show | display set | no-more
set version 10.1R1.8
set system root-authentication encrypted-password “$1$So35lYmi$6DDH4xxP9SLIdrwCfCs65.”

[edit]
root# delete
This will delete the entire configuration
Delete everything under this level? [yes,no] (no) yes 

[edit]
root# set system root-authentication plain-text-password 
New password:
Retype new password:

[edit]
root# set system login user Juniper class super-user authentication plain-text-password 
New password:
Retype new password:

[edit]
root# set system services ftp

[edit]
root# set interfaces fe-0/0/0.0 family inet address 192.168.0.1/24

[edit]
root# set security zones security-zone trust interfaces fe-0/0/0
(SRX以外ではこの設定は不要です)

[edit]
root# set security zones security-zone trust host-inbound-traffic system-services ftp
(SRX以外ではこの設定は不要です)

[edit]
root# show | display set | no-more
set system root-authentication encrypted-password “$1$RAyhg/8B$G.shSH3EKdebnleA.4mR.0″
set system login user Juniper class super-user
set system login user Juniper authentication encrypted-password “$1$btn92z6F$IGD5lj2Veh9fDgQ7UpDZu0″
set system services ftp
set interfaces fe-0/0/0 unit 0 family inet address 192.168.0.1/24
set security zones security-zone trust host-inbound-traffic system-services ftp
set security zones security-zone trust interfaces fe-0/0/0.0

[edit]
root# commit and-quit
commit complete
Exiting configuration mode

root>

ここまでJunosアップグレードの準備は整いました ではJunosのアップグレードを実施しましょう。
Junosのアップグレード時に使用するコマンドは次のとおりです
> request system software add <パッケージファイル名>
パッケージファイル名の部分はファイルまでのパスを含みます
例えばJuniper製品の内部にインストールファイルをコピー済みの場合は
 request system software add /var/tmp/jinstall-10.1R1.8-domestic-signed.tgz
となります
今回はFTPサーバから直接Junosパッケージファイルを取得する方法をとります。
FTPサーバのIPアドレスは192.168.0.100/24です。
JunosインストールパッケージはFTPサーバーのルートフォルダ直下に置いてあります。
SRXのfe-0/0/0ポートを使用してサーバと接続を行うこととします
使用するFTPサーバのID,パスワードは次のように設定されています。
FTPサーバの認証設定
ID myname
Password mypass
また今回は”no-copy“オプションを使ってJunosインストールイメージがSRX上に保存されないようにしています。これはSRX100Bはメモリ空きが少ない為です。
Junosのインストールには時間がかかりますのでこの間に休憩を取りましょう。 
(SRX100の場合で約30分ほどかかります)
root> request system software add no-copy ftp://myname:mypass@192.168.0.100/junos-srxsme-10.1R2.8-domestic.tgz
/var/tmp/incoming-package.1655                        1040 kB 1040 kBps
Package contains junos-10.1R2.8.tgz ; renaming …
NOTICE: Validating configuration against junos-10.1R2.8.tgz.
NOTICE: Use the ‘no-validate’ option to skip this if desired.
Formatting alternate root (/dev/da0s1a)…
/dev/da0s1a: 297.9MB (610028 sectors) block size 16384, fragment size 2048

using 4 cylinder groups of 74.47MB, 4766 blks, 9600 inodes.
super-block backups (for fsck -b #) at:
 32, 152544, 305056, 457568
Checking compatibility with configuration
Initializing…
veriexec: cannot update veriexec for /var/validate/chroot/junos/etc/voip/musiconhold.conf: No such file or directory
Verified manifest signed by PackageProduction_10_1_0
Verified junos-10.1R1.8-domestic signed by PackageProduction_10_1_0
Using junos-10.1R2.8-domestic from /altroot/cf/packages/install-tmp/junos-10.1R2.8-domestic
Copying package …
Saving boot file package in /var/sw/pkg/junos-boot-srxsme-10.1R2.8.tgz
veriexec: cannot update veriexec for /cf/var/validate/chroot/junos/etc/voip/musiconhold.conf: No such file or directory
Verified manifest signed by PackageProduction_10_1_0
Hardware Database regeneration succeeded
Validating against /config/juniper.conf.gz
cp: /cf/var/validate/chroot/var/etc/resolv.conf and /etc/resolv.conf are identical (not copied).
cp: /cf/var/validate/chroot/var/etc/hosts and /etc/hosts are identical (not copied).
mgd: commit complete
Validation succeeded
Installing package ‘/altroot/cf/packages/install-tmp/junos-10.1R2.8-domestic’ …
Verified junos-boot-srxsme-10.1R2.8.tgz signed by PackageProduction_10_1_0
Verified junos-srxsme-10.1R2.8-domestic signed by PackageProduction_10_1_0
Saving boot file package in /var/sw/pkg/junos-boot-srxsme-10.1R2.8.tgz
JUNOS 10.1R2.8 will become active at next reboot
WARNING: A reboot is required to load this software correctly
WARNING:     Use the ‘request system reboot’ command
WARNING:         when software installation is complete
Saving state for rollback …

root> 

インストールが正常に終了した事を確認したら再起動を実施します
(ここまでで行われたのはインストーラの展開のみです 実際のインストールは再起動後に実施されます インストール終了後に自動的に2度目の再起動が行われます)
root> request system reboot
Reboot the system ? [yes,no] (no) yes

Shutdown NOW!
[pid 2381]

~ 略 ~
再起動が終了したら起動デバイスとJunosバージョンの確認を行いましょう
Juniper> show version
Model: srx100-lm
JUNOS Software Release [10.1R2.8]

Juniper> show system storage 
Filesystem              Size       Used      Avail  Capacity   Mounted on
/dev/da0s1a             293M       190M        79M       71%  /
devfs                   1.0K       1.0K         0B      100%  /dev
/dev/md0                529M       529M         0B      100%  /junos
/cf                     293M       190M        79M       71%  /junos/cf
devfs                   1.0K       1.0K         0B      100%  /junos/dev/
procfs                  4.0K       4.0K         0B      100%  /proc
/dev/bo0s3e              24M        20K        22M        0%  /config
/dev/bo0s3f             342M        22M       293M        7%  /cf/var
/dev/md1                 84M        12M        65M       16%  /mfs
/cf/var/jail            342M        22M       293M        7%  /jail/var
/cf/var/log             342M        22M       293M        7%  /jail/var/log
devfs                   1.0K       1.0K         0B      100%  /jail/dev
/dev/md2                1.8M       4.0K       1.7M        0%  /jail/mfs

Juniper>


ここでJunosのバージョンが上がっていることがわかります
 10.1R1.8 ⇒ 10.1R2.8 (マイナーバージョンアップ)

以上でJunosのバージョンアップ作業は終了です
 
2010/7/31 追記:
 ”request system software add”コマンド実行時に”reboot”オプションを付加するとインストーラ展開終了後に自動的に再起動することができます
 
2013/11/28 追記:
 ”no-validate”オプションを使用することによりバージョン間の互換性チェックをスキップする事ができますが3世代を超えてバージョンアップをすると正式なサポートが受けられない可能性がありますので注意が必要です。
 
メモ:
 検証環境の構成図が無いので後ほど追記いたします。

タグ

2010年7月11日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

JUNOSのアップグレード (準備編)

今回と次回の二回にわたりJunosのアップグレード方法について説明したいと思います

まず最初にJuniper製品をアップグレードをするためのJunosを用意しなくてはなりません

これはベンダーに用意させるか会社のアカウントでJuniperからダウンロードするかのどちらかになります
Junos_sw_logo.jpg

Junosのインストールパッケージは以下のようなファイル命名規則があります
XXXXX-m.nYa.b-CRPTYPE.tgz

XXXXXはパッケージ種別を表し、m.nはリリース番号、Yはリリースタイプ、a.bはリリースタイプ別のバージョン、CRPTYPEは適用地域範囲を表します

・パッケージ種別
一般的に入手可能なJunosパッケージ種別は2種類あります
また機種ごとにバイナリーが違うので注意が必要です

M/Tシリーズ向け
jinstall-m.nYa.b-CRPTYPE.tgz
jbundle-m.nYa.b-CRPTYPE.tgz

EXシリーズ向け
jinstall-EX-<chassis>m.nYa.b-CRPTYPE.tgz
jbundle-EX-<chassis>-m.nYa.b-CRPTYPE.tgz
部分には次のいずれかが入ります
2200 ・・・EX2200シリーズ向け
3200 ・・・EX3200シリーズ向け
4200 ・・・EX4200シリーズ向け
8200 ・・・EX8200シリーズ向け

Jシリーズ向け
junos-jsr-m.nYa.b-CRPTYPE.tgz

SRXシリーズ向け
junos-srx<chassis>-m.nYa.b-CRPTYPE.tgz
<chassis>部分には次のいずれかが入ります
sme ・・・burach向けSRXシリーズ向け
3000 ・・・SRX3000
5000 ・・・SRX5000

LN1000V向け
junos-ln-m.nYa.b-CRPTYPE.tgz

Junosのインストールに使用するのは通常”jbundle”となりFreeBSDのOSバージョンアップを含む場合は”jbundle”パッケージが使用されます
その他にもパッケージは存在しますがすべて”jinstall”に内包されています (詳しくは後日、別途記事を作成します)

・リリース番号
Junosは4半期に一度マイナーバージョンアップを実施いたします
現在のJunos最新はJunos 10.2です
このJunos 10.2が2010/5/28にリリースされていますので次回は8月にJunos 10.3がリリースされると判断できます
そしてマイナーバージョンアップを重ねOSに大きな変更が加わった場合にメジャーバージョンアップが実施されます

・リリースタイプ
通常入手可能なJunosのバージョンには主に2種類あります

4半期に1度のタイミングでリリースされる標準リリース、バグフィックス対応のためのサービスリリースです
R=標準リリース S=サービスリリース
なおサービスリリースに関しては通常のOSダウンロードページのリストへは載せられていません
新しいサービスリリース情報の入手には追加でJTACメーリングリストへの登録が必要になります
その他にも次のようなリリースタイプもありますが、主にJuniper社内でビルドテストに使われるものなのでわたしは見たことはありません

A=αリリース B=βリリース

・適用地域範囲
JunosにはUS及びカナダ用と全世界向けの2種類のバイナリが存在しています
これはアメリカの法律で軍事的な理由より暗号化の輸出に規制が掛けられているため、アメリカ国内向けとその他地域向けのJunosバイナリが用意されているのです
domestic ・・・・ アメリカ国内向けバイナリイメージ
export ・・・・・・ 全世界向けバイナリイメージ

ここまででJunosアップグレードの準備は整いました
続きは次回にいたします

追記:
Junosのアップデートは90日毎のようです

One of the key things that JUNOS has delivered to Juniper customers is a degree of predictability. Every 90 days there is a new release providing fixes and improving functionality. It’s a relentless development cycle that is critical to Juniper’s business.

ソース:
http://itmanagement.earthweb.com/osrc/article.php/3760411/JUNOS:+Open,+but+Not+Open+Source.htm

2013/03/24 更新

タグ

2010年7月4日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

ログ保存とコンフィグ流しこみ

久々に技術的なブログを書きます

最初にログの保存方法です
JUNOSで現状のキャンデティト・コンフギュレーションを出力させるためにはshowコマンドを実施します
ただし、showコマンドを実施しますと1ページごとに
—(more)—
と出力されてしまいます
moreを出力させないためには
show | no-more
を実施します”no-more”コマンドはshow以外のコマンドでも有効です
ユーザがログアウトするまでページングを無効にするためにはオペレーショナルモードで下のコマンドを実施します
>set cli screen-length 0
コンフィギュレーションモードからオペレーショナルモードのコマンドを実施したい場合は実施するコマンドの前にrunを付け加えます
#run set cli screen-length 0
JUNOSのrunコマンドはciscoで使えるdoコマンドとは違い”tabキー”や”?”を使うことができます
I love JUNOS !
しかし、JUNOSの設定はご存知のとおりset形式で実施します
このset形式でコンフィグを表示させるには、
#show | display set
を実施します 先ほどの”no-more”と組み合わせて
#show | display set | no-more
を実行すると良いでしょう
次はコンフィグの流し込みです
コンフィグをコンソール端末から流し込みを行う場合には
#load override terminal
を実施、コンフィグを流し終えたら、Ctrl-Dで終了です
念のためですがcommitで設定反映を忘れずに

タグ

2009年11月8日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

OSPFの設定(2)

前回はベーシックなOSPFの設定を実施しました

では今回は、redistribute-staticを実践してみたいと思います

Building configuration…

Current configuration : 671 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet0
 ip address 192.168.0.2 255.255.255.0
 shutdown
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.0.255 area 0
!
ip http server
ip classless
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

 

JUNOSの設定をしてみましょう、前回までの設定でconfigは下のようになっています

root# show | no-more
## Last changed: 2009-10-11 20:45:39 UTC
version 8.3R2.8;
system {
    root-authentication {
        encrypted-password “$1$nIAA3PPr$ZKvo645RSZFDGCmfweQRb1″; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 192.168.0.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.1.1/32;
            }
        }
    }
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface fxp0.0;
            interface lo0.0;
        }
    }
}

まずは次のstaticルートを追加してみます
[edit]
root# set routing-options static route 172.30.0.0/24 next-hop 192.168.0.250

ではredistributeするスタティックルートのポリシーを作成しましょう
Junosでは”set policy-options policy-statement <ポリシー名>”で設定をします
[edit]
root# set policy-options policy-statement REDIST_STATIC term 10 from protocol static

[edit]
root# set policy-options policy-statement REDIST_STATIC term 10 from protocol direct

[edit]
root# set policy-options policy-statement REDIST_STATIC term 10 then accept

[edit]
root# set policy-options policy-statement REDIST_STATIC then reject

最後に作成したポリシーをospfプロトコル設定に反映します
[edit]
root# set protocols ospf export REDIST_STATIC

これでスタティックルーティングがredistributeされているはずですのでCisco側で確認してみましょう
Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/24 is subnetted, 1 subnets
O E2    172.30.0.0 [110/0] via 192.168.0.1, 00:00:11, Ethernet0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       10.0.1.1/32 [110/10] via 192.168.0.1, 00:00:11, Ethernet0
C       10.0.0.0/24 is directly connected, Loopback0
C    192.168.0.0/24 is directly connected, Ethernet0
Router#

ちゃんとスタティックルートがredistributeされていることが確認できました
次回は、ルータIDの設定、stabエリアの設定等、まだまだやることが沢山ありますね

タグ

2009年10月11日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

OSPFの設定(1)

今回はOSPFの基本設定について解説していきたいと思います

ますは前提となるセグメント情報ですが、次のようになっています

使用ルータ JUNOS-BOX x1、2501 x1

Cisco⇔Juniper間のセグメント・・192.168.0.0/24
  Juniper側 fxp0・・・・・・192.168.0.1
  Cisco側 Ethernet0・・192.168.0.2
Ciscoのloopbackアドレス・・・・・・10.0.0.1/24
Juniperのループバックアドレス・・10.0.1.1/32

全て、OSPF エリア0で設定します

今回の2501ルータの設定は次のようにしました

Building configuration…

Current configuration : 654 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.0
 –More–         !
interface Ethernet0
 ip address 192.168.0.2 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.0.255 area 0
!
ip http server
ip classless
!
!
!
 –More–         !
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
end

では、JUNOS-BOXの設定を実施してみましょう
なお、各インターフェースへIP設定は終了しているものとします

JUNOSでOSPFの設定を行う場合は次のコマンドで実施します

set protocols ospf area エリア番号 interface インターフェース名

少し、ややこしいかもしれませんが、OSPFはprotocols階層にあり、
OSPFエリアごとにどのinterfaeceで使用するかを割り当てていきます

では、ospf area 0へfxp0とlo0の設定をしてみましょう

[edit]
root# set protocols ospf area 0 interface fxp0

[edit]
root# set protocols ospf area 0 interface lo0 set protocols ospf area 0 interface lo0
[edit]

できあがった コンフィグを確認してcommitしましょう

[edit]
root# show | no-more
## Last changed: 2009-10-11 08:10:58 UTC
version 8.3R2.8;
system {
    root-authentication {
        encrypted-password “$1$nIAA3PPr$ZKvo645RSZFDGCmfweQRb1″; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 192.168.0.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.1.1/32;
            }
        }
    }
}
protocols {
    ospf {
        area 0.0.0.0 {
            interface fxp0.0;
            interface lo0.0;
        }
    }
}

[edit]
root# commit
commit complete

[edit]
root#

ではOSPFが想定どおりに動作しているか確認します

次のコマンドを使って確認してみましょう

show ospf database
show route

コンフィギュレーションモードから実施するために各コマンドの前に run を入れてから実施します 

root# run show ospf database

    OSPF link state database, Area 0.0.0.0
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len
Router   10.0.0.1         10.0.0.1         0×80000004   906  0×22 0xde40  48
Router  *10.0.1.1         10.0.1.1         0×80000004   901  0×22 0×1314  48
Network *192.168.0.1      10.0.1.1         0×80000001   906  0×22 0x525a  32

root# run show route

inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, – = Last Active, * = Both

10.0.0.1/32        *[OSPF/10] 00:15:35, metric 2
                    > to 192.168.0.2 via fxp0.0
10.0.1.1/32        *[Direct/0] 00:20:33
                    > via lo0.0
192.168.0.0/24     *[Direct/0] 00:20:33
                    > via fxp0.0
192.168.0.1/32     *[Local/0] 00:20:33
                      Local via fxp0.0
224.0.0.5/32       *[OSPF/10] 00:20:33, metric 1
                      MultiRecv

__juniper_private1__.inet6.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
+ = Active Route, – = Last Active, * = Both

fe80::2e0:b6ff:fe06:286b/128
                   *[Direct/0] 00:26:54
                    > via lo0.16385

[edit]
root#   

正常にOSPFが動作していそうです、では各インターフェースへping疎通確認を行ってみましょう

[edit]
root# run ping 192.168.0.1 count 5 rapid
PING 192.168.0.1 (192.168.0.1): 56 data bytes
!!!!!
— 192.168.0.1 ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.025/0.034/0.065/0.016 ms

[edit]
root# run ping 192.168.0.2 count 5 rapid
PING 192.168.0.2 (192.168.0.2): 56 data bytes
!!!!!
— 192.168.0.2 ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.756/2.877/3.182/0.155 ms

[edit]
root# run ping 10.0.0.1 count 5 rapid
PING 10.0.0.1 (10.0.0.1): 56 data bytes
!!!!!
— 10.0.0.1 ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.907/3.163/3.593/0.257 ms

[edit]
root# run ping 10.0.1.1 count 5 rapid
PING 10.0.1.1 (10.0.1.1): 56 data bytes
!!!!!
— 10.0.1.1 ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.025/0.034/0.066/0.016 ms

[edit]
root#

OSPFの基本設定はこれで終わりです

タグ

2009年10月10日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

JUNOS 9.6

Juniper Vlogよりお知らせです JUNOS 9.6が発表されました
9月にはもう9.6は世に出てダウンロード出来ていた気がしなくもないですが,
新OSの機能を説明してくれています

リリースノートを見たほうが効率が良いという話は置いておくとしましょう

JUNOSバージョンの話をしましたのでついでの報告です
今、リモートラボのJUNOSバージョンを8.4へアップグレード作業中ですが、やはりいろいろと機能が追加されていますね7.4では通らなかったコマンドが使えるようになっていました

タグ

2009年10月3日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

時間設定

今回は軽くJUNOSの時刻設定について紹介いたします

 CLIより時刻設定を行う場合には次のコマンドを使用します

set date YYYYMMDDhhmm.ss

実際に実行してみましょう

root> set date 200909281025.44
date: connect: Can’t assign requested address
Mon Sep 28 10:25:44 JST 2009

root>

 
なおJuniperルータのデフォルトのタイムゾーンはUTCになっておりますのでこれをAsia/Tokyoへ変更します

root> configure
Entering configuration mode

[edit]
root# set system time-zone Asia/Tokyo

[edit]
root#

最後にNTPの設定実施です 

[edit]
root# set system ntp server 192.168.1.100

[edit]
root# set system ntp boot-server 192.168.1.100

[edit]
root#

ここでntp boot-serverはルータ起動時にNTPリクエストを要求するNTPアドレスです

タグ


2009年9月28日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

RIPの設定 (2)

昨日に引続きRIPの設定を見ていきましょう

先ず、対抗ルータのloopback0へpingを実施してみましょう

[edit]
root# run ping 172.16.0.1 count 5 rapid
PING 172.16.0.1 (172.16.0.1): 56 data bytes
!!!!!
— 172.16.0.1 ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.055/0.073/0.141/0.034 ms

[edit]
root#

問題なく疎通確認ができました
ちなみに上のようにpingへcount 5オプションとrapidオプションを付加させてあげる事により某社ルータと同じような出力を得ることができます
では対抗側の250側0よりこちら側のlo0インターフェースは見えているのでしょうか?
早速確認してみましょう

test-router>ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
test-router>

おやおや? 通信確認ができていません
ではJUNOS側に次のコンフィグを上書きしてみてください

[edit]
root# load override terminal
[Type ^D at a new line to end input]
version 7.4R3.4;
system {
    root-authentication {
        encrypted-password “$1$IRx5CsNE$9fS4RQv8HpGFlXW9E6T8T.”; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    fxp0 {
        unit 0 {
            family inet {
                address 172.16.0.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.10.1/32;
            }
        }
    }
}
protocols {
    rip {
        group plan-g {
            export redist-direct;
            neighbor fxp0.0;
        }
    }
}
policy-options {
    policy-statement redist-direct {
        from protocol direct;
        then accept;
    }
}

load complete

[edit]
root#

では、投入したコンフィグが前回のコンフィグと何が違うか見てみましょう

[edit]
root# show |compare
[edit protocols rip group plan-g]
+    export redist-direct;
[edit]
+  policy-options {
+      policy-statement redist-direct {
+          from protocol direct;
+          then accept;
+      }
+  }

[edit]
root#

lo0インターフェースはダイレクト接続となっているので、redistribute directつまりダイレクト接続されたlo0のルート情報を再広報していますね
ではcommitを実施し2500から見えるようになったか確認してみましょう

test-router>ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
test-router>

pingによる接続性の確認が取れました

以上、JUNOSのRIPルーティングでした

タグ

2009年9月27日 | コメント/トラックバック(0) |

カテゴリー:JUNOS

このページの先頭へ